Prefect Cloud occasionally undergoes routine scheduled maintenance, which results in delayed work during this window. Prefect strives to publish upcoming maintenance events on this page at least 7 days in advance.
A JSON summary of the status page is also available. See https://status.prefect.io/api/v1/summary.
Looking for Horizon's status page? See https://status.horizon.prefect.io.
Resolved
Between roughly 15:50 and 16:15 UTC, some requests intermittently returned errors. Execution of flows and tasks was unaffected. Service returned to normal by ~16:15 UTC.
Identified
We are investigating an issue causing intermittent errors when loading flow run lists and details in the UI and API. Other Prefect Cloud functionality - including flow run execution, scheduling, and task orchestration - is not affected, and your workflows continue to run normally.
Affected requests may return a 503 error and can be retried. Our engineering team has identified the source and is actively working on remediation. We will provide another update shortly.