Prefect Cloud occasionally undergoes routine scheduled maintenance, which results in delayed work during this window. Prefect strives to publish upcoming maintenance events on this page at least 7 days in advance.
A JSON summary of the status page is also available. See https://status.prefect.io/api/v1/summary.
Looking for Horizon's status page? See https://status.horizon.prefect.io.
Resolved
The issue affecting the Prefect Cloud API and UI has been fully resolved and all services are operating normally, including background processing. We apologize for the disruption.
Monitoring
The underlying database issue has been resolved and the system is recovering. API error rates are dropping and flow run scheduling is catching up. Some automations and event processing may remain delayed while a backlog clears.
Investigating
We're investigating elevated errors and degraded orchestration performance affecting Prefect Cloud (US). Some API requests may return errors and flow run scheduling may be delayed. We're actively working to resolve this and will post updates as we learn more.